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1# main_index
2$ Help Index
3+ index:0005



#4 The Index contains a list of all Help topics available for Windows Info-ZIP Unzip. For 
information on how to use Help, press F1 or choose Using Help from the Help menu.

4# index_info



#5$6+7What Is WizUnzip ?

WizUnzip stands for Windows Info-ZIP Unzip. WizUnzip is a Microsoft Windows application 
which extracts, tests, and displays files archived in ZIP archive format.

WizUnzip is derived from a co-operative effort by a number of developers collectively known 
as Info-ZIP. (See Who is Info-ZIP ?). Info-ZIP's goal is to provide widely-available, non-
commercial archiving tools compatible with Phil Katz's popular DOS application products, 
pkzip and pkunzip. Info-ZIP's counterpart products are called zip and unzip respectively.

The unzip logic of WizUnzip is based on Info-ZIP's product unzip, which has been ported to a 
number of platforms.WizUnzip is essentially unzip with a Microsoft Windows interface and a 
little extra logic to display files as well as to extract them. Unzip is based on earlier works by
Samuel Smith and Carl Mascott. 

In keeping with Info-ZIP's goals, WizUnzip is available on a not-for-profit basis. (See 
Copyright and Distribution.)

5# HELPID_WHAT_IS
6$ What Is WizUnzip ?
7+ intro:010



#8$9+10Edit Menu

The Edit menu includes commands that let you globally select or de-select listbox contents 
or to clear the Messages Window.

For more information, select an Edit menu command name from below.

De-select All Listbox Entries De-selects and unhighlights all files in the archive.
Select All Listbox Entries Selects all listbox entries.
Clear Messages Window Clears the contents of the Messages Window.

8# HELPID_EDIT
9$ Edit Menu
10+ commands:020



#11$12+13De-select All Listbox Entries

This menu item de-selects and unhighlights all files in the listbox. 

WizUnzip dims the three buttons Extract, Display, and Test. 

You may then select one or more files in the listbox using the pointer or the keyboard. 

Selecting one or more files in the listbox causes the buttons to become active again. 

Select any of the buttons to operate on the selected files.

Pressing the F3 key is a short-cut to de-selecting all listbox entries.

11# HELPID_DESELECT_ALL
12$ De-select All Listbox Entries
13+ edit_menu:060



#14$15+16 Select All Listbox Entries

This menu item selects and highlights all files in the listbox. 

WizUnzip activates the three Extract, Display, and Test buttons. 

Select any of the three buttons to operate on all files in the archive.

Pressing the F2 key is a short-cut to selecting all listbox entries.

14# HELPID_SELECT_ALL
15$ Select All Listbox Entries
16+ edit_menu:070



 #17$18+19Clear Messages Window

This menu item clears the Messages window.    

WizUnzip automatically clears your Messages Window if its contents would either exceed the
amount of global memory space available in your system or reach 65535 characters.

Pressing the Del key is a short-cut to clearing the Messages window.

17# HELPID_CLEAR_STATUS
18$ Clear Messages Window
19+ edit_menu:080



#20$21+22File Menu

The File menu includes the following commands:

File Menu Open Command Opens an archive and lists its directory.
File Menu Unzip To Command Changes the extraction directory.
File Menu Exit Command Exits WizUnzip.

20# HELPID_FILE
21$ File Menu
22+ commands:010



#23$24+25File Menu Open Command

The File menu's Open command leads to the Open a ZIP File dialog box.

Open a ZIP File Dialog Box

This dialog box lets you select the ZIP archive on which you may perform further operations.
Select the directory in which the ZIP archive is found. 
When you select a directory,    WizUnzip lists all of the .ZIP files in the Files listbox. 
The Filenames: field starts out as a template of all the ZIP archives in the directory.

Select an archive either by clicking on its filename from the Files listbox or by typing its 
name in the Filenames edit box.
Select the OK button to put your choice into effect. 
 
Select the Cancel button if you wish to return to the current .ZIP file.

When you open a .ZIP file, WizUnzip displays the archive contents in the Archive Directory 
Listbox of its main window. WizUnzip does not automatically extract the contents.    See 
Extracting Files from the Archive to find out how this is done. 

You may unzip the archive contents either into the directory where the .ZIP file lives or into a
separate directory.
See the File Menu Unzip To Command and the Unzip to Same Directory as .ZIP item under 
the Options Menu for more information.

23# HELPID_OPEN
24$ File Menu Open Command
25+ menu_file:030



#26$27+28File Menu "Unzip To" Command

This command lets you change the directory into which WizUnzip extracts the current .ZIP 
archive. 
You may extract files into a directory other than the one in which the ZIP archive file resides. 

If this command is grayed, you may enable it by toggling the Unzip to Same Directory 
as .ZIP item under the Options Menu.

If you don't select a destination directory, WizUnzip assumes you wish to extract files into 
the directory of the first archive you open. 
The "Unzip To" command produces the Unzip Destination Directory Dialog Box.

Unzip Destination Directory Dialog Box

This dialog box lets you browse and select a destination directory into which you can unzip.

The Current directory into which WizUnzip extracts: field shows where WizUnzip will extract 
files.

You may designate some other directory by either:

1) Entering a new directory path in the Directory you prefer: field, or
2) Repeatedly selecting directories from the Directories listbox.

A single dot in the Directory you prefer: field stands for the current directory.
.
Select the OK button to change to the new directory.    
When you have selected '.' as the directory you prefer, WizUnzip changes to the directory 
shown in the Current directory into which WizUnzip extracts:  field.
The new destination directory is shown on the title bar.

Select the Cancel button to return to the directory displayed on entry. 

26# HELPID_CHDIR
27$ File Menu Change Directory Command
28+ menu_file:35



#29$30+31File Menu Exit Command

This command takes you out of WizUnzip. To find out other ways to exit WizUnzip, see 
Exiting WizUnzip.

29# HELPID_EXIT_CMD
30$ File Menu Exit Command
31+ menu_file:40



#32$33+34Exiting WizUnzip

You may exit WizUnzip by any of the following methods:
1) typing Alt-F4, 
2) selecting the Files menu then the Exit menu item, or    
3) selecting WizUnzip's system menu then the Close menu item.

You may safely exit WizUnzip at any time without fear of losing data.

32# HELPID_EXITING
33$ Exiting WizUnzip
34+ procedures:100



#35$36+37K38Options Menu

The Options menu lets you specify how WizUnzip handles directories, whether or not 
WizUnzip should overwrite existing files during extraction,    what WizUnzip does when you 
select one or more files in the listbox, and to where WizUnzip extracts files from the archive.

For more information, select any of the following four items:

Recreate Directory Structure lets you extract subdirectories or not.

Overwrite Existing Files controls overwriting existing files.

Translate CR-LF to LF optionally translates CR/LF character pair to LF 
character.
Unzip to Same Directory as .ZIP controls whether you unzip in .ZIP or other 
directory.

These items let you define the action taken when you double-click on a file named in the 
listbox. 

Listbox Selection Extracts File Double click extracts.
Listbox Selection Tests File Double click tests.
Listbox Selection Displays File Double click displays.

WizUnzip saves your option selection permanently until you replace it with another.

35# HELPID_OPTIONS
36$ Options Menu
37+ commands:030
38K options



#39$40+41K42Recreate Directory Structure

During file extraction this option specifies whether or not WizUnzip re-creates subdirectories 
saved within the archive. 

When this option is active, a checkmark appears beside its menu item.

When this option is active, WizUnzip extracts, preserving the directory structure present in 
the archive.

When this option is not active, WizUnzip extracts the files from subdirectories listed in the 
archive into the parent directory.

WizUnzip saves the setting of this option in your WIN.INI file until you change it again 
through the menu.

39# HELPID_RECR_DIR_STRUCT
40$ Recreate Directory Structure
41+ options:010
42K directory;extracting



#43$44+45K46Overwrite Existing Files Option

When you choose this option, WizUnzip automatically overwrites each existing file that it 
finds during extraction. 
WizUnzip places a check mark beside the menu item to show that the option is in force.

WizUnzip saves the setting of this option in your WIN.INI file until you change it again 
through the menus.

Overwrite Existing Files Dialog Box

When you don't choose the Overwrite Existing Files option, WizUnzip prompts you with a 
dialog box for each existing file that it would replace during extraction. The dialog box 
prompt gives you three alternatives. 
You may:

1) skip the file without extracting it (the default),
2) overwrite the file,
3) overwrite the current file and all others in the same operation.

The Overwrite Existing Files Dialog Box has no effect on the more permanent Overwrite 
Existing Files Option.

43# HELPID_OVERWRITE
44$ Overwrite Existing Files
45+ options:020
46K extracting



#47$48+49K50Translate CR-LF to LF

Choose this option only if you are extracting text files and wish to translate them into the 
format used by a UNIX or similar computer. In the UNIX text file format, lines of text are 
separated by only a linefeed character. Lines of text within DOS files are typically separated 
by the two carriage return, linefeed characters. 

Do not choose this option if you are extracting a binary file.    Since WizUnzip can't tell the 
difference between text and binary files, you have to decide when to use it.    In general, 
don't choose this option unless you're sure you need it.

WizUnzip places a check mark beside the menu item to show that the option is in force. The 
setting you choose stays in effect until you toggle it. 

47# HELPID_TRANSLATE
48$ Translate LF to CR-LF
49+ options:030
50K extracting



#51$52+53K54Unzip to Same Directory as .ZIP

Choose this option only if you want WizUnzip to always extract the contents of the .ZIP file in
the same directory in which the ZIP archive is located.    This option saves having to set the 
extraction directory separately. 

When WizUnzip is set to unzip in the same directory as the .ZIP file, WizUnzip disables and 
grays the File Menu Unzip To Command . 

When you do not select this option, WizUnzip enables the File Menu Unzip To Command,
 and you may select the destination directory.

WizUnzip places a check mark beside the menu item to show that the option is in force. The 
setting you choose stays in effect until you toggle it. 

WizUnzip's title bar always shows the name of the directory into which it extracts regardless 
of the option's setting.

51# HELPID_UNZIP_TO_ZIP_DIR
52$ Unzip to Same Directory as .ZIP
53+ options:040
54K extracting



#55$56+57K58Listbox Selection Extracts File

When this option is active, double-clicking on a listbox entry extracts the selected file(s) 
from the archive and logs the outcome in the Messages Window.

55# HELPID_LB_EXTRACT
56$ Listbox Selection Extracts File
57+ options:050
58K extracting



#59$60+61K62Listbox Selection Displays File

When this option is active, double-clicking on a listbox entry displays the file(s) in the 
Messages Window. 

59# HELPID_LB_DISPLAY
60$ Listbox Selection Displays File
61+ options:060
62K extracting



#63$64+65K66Listbox Selection Tests File

When this option is active, double-clicking on a listbox entry tests the file(s) within the 
archive and displays the results in the Messages Window. 

63# HELPID_LB_TEST
64$ Listbox Selection Tests File
65+ options:070
66K extracting



#67$68+69K70View Menu

The View menu directs    WizUnzip to display the archive contents in either Long Format or 
Short Format.

WizUnzip places a check mark beside the menu item which is currently selected.

67# HELPID_VIEW
68$ View Menu
69+ commands:040
70K format



#71$72+73K74Long Format

In long format WizUnzip's Archive Directory Listbox shows: 

the file length in Kbytes before archiving,
the ZIP method of archiving: e.g. imploding, storing, shrinking, reducing.
the file size in Kbytes as it is stored within the archive,
the compression ratio,
the file modification date,
the file modification time,
the 32-bit cyclic redundancy check value, used for integrity checking,
the file name.

71# HELPID_LONG
72$ Long Format
73+ format:010
74K format



#75$76+77K78Short Format

In short format WizUnzip's Archive Directory Listbox shows: 

the file length in Kbytes before archiving,
the file modification date,
the file modification time,
the file name.

75# HELPID_SHORT
76$ Short Format
77+ format:020
78K format



#79$80Glossary

DOS
FTP
Internet
UNIX
ZIP archive

79# glossary
80$ Glossary



81#82$83K84DOS

The DOS operating system popular on IBM-compatible personal computers. 
It's probably running on your PC right now. 
DOS usually is short for MS-DOS, a trademark of Microsoft.

81
82# term_DOS
83$ DOS
84K DOS



85#86$87K88FTP

File Transfer Protoocol. A software application or a protocol for transferring files through the 
Internet.

85
86# term_FTP
87$ FTP
88K FTP



89#90$91K92Internet

A data network connecting many universities, corporations, and government institutions.

89
90# term_Internet
91$ Internet
92K Internet



93#94$95K96UNIX

The UNIX operating system is popular on multi-user open computer systems.

93
94# term_UNIX
95$ UNIX
96K UNIX



97#98$99K100ZIP archive

A ZIP archive is a collection of files stored within a single file in the format implemented by 
Phil Katz's products pkzip and pkunzip as well as Info-ZIP's products zip and unzip. ZIP 
archive files typically have the suffix .ZIP.

97
98# term_ZIP_archive
99$ ZIP_archive
100K ZIP_archive



#101$102+103K104Browsing Text in the Archive

To browse one or more files within the archive, first select the files using the listbox then 
select the Display Button either by clicking on it or by typing Cntl-D.    The given file will be 
copied into the Messages Window where it can be scrolled using the horizontal and vertical 
scroll bars.

Alternately, you may use the Options menu to let you automatically display a file whenever 
you select its name in the listbox.    To do so, select the Options menu then select the item 
Listbox Selection Displays File..  Whenever you double-click on a filename in the listbox, 
WizUnzip displays a copy in the Messages window. WizUnzip saves this setting in your 
WIN.INI file until you change it.

WizUnzip cannot distinguish between text and data files, so it is possible to copy a data file 
into the Messages Window. WizUnzip assumes that the files it copies to the Messages 
Window are in the PC manufacturer's OEM codeset, which WizUnzip translates to the ANSI 
character set. 

101# HELPID_DISPLAYING
102$ Browsing Text in the Archive
103+ procedures:050
104K browsing



#105$106+107K108Extracting Files from the Archive

First select the files you wish to extract, using the Archive Directory Listbox . Next select the 
Extract Button by clicking on it or by typing Cntl-X.    WizUnzip extracts the files, placing 
them in the current directory. The Messages Window lists the names of the files as they are 
extracted.

Alternately, you may use the Options menu to let you automatically extract a file whenever 
you double-click on its name in the listbox.    To do so, select the Options menu then select 
the item Listbox SelectionExtracts File.  Now when you double-click on a filename in the 
listbox, WizUnzip will extract it. WizUnzip saves this setting in your WIN.INI file until you 
change it.

105# HELPID_EXTRACTING
106$ Extracting Files from the Archive
107+ procedures:110
108K extracting;de-archiving



#109$110+111K112Testing Files in the Archive

First select the files you wish to test, using the Archive Directory Listbox. Next select the Test
button by clicking on it or by typing Cntl-T.    WizUnzip tests the files, listing the file names 
and results as they are tested.

Alternately, you may use the Options menu to let you automatically test a file whenever you 
double-click on its name in the listbox.    To do so, select the Options menu then select the 
item Listbox Selection Tests File         Afterwards when you double-click on a filename in the 
Archive Directory Listbox, WizUnzip will test it. WizUnzip saves this setting in your WIN.INI 
file until you change it.

109# HELPID_TESTING
110$ Testing Files in the Archive
111+ procedures:120
112K testing



#113$114+115K116Opening an Archive File

Before WizUnzip can operate on an archive file, you must open an archive file. WizUnzip only
operates on archive files in .ZIP format. .ZIP files are created either by Phil Katz's PKZIP 
program or by Info-ZIP's ZIP program. ZIP files are identified by their .ZIP suffix.

You may open a .ZIP file either by passing its name to WizUnzip when you start WizUnzip or 
by using WizUnzip's File Menu   Open Command  . You may find it useful to let Windows' File 
Manager associate the .ZIP suffix with WizUnzip for easy browsing and extraction of .ZIP 
files.

When the archive file has been successfully opened, its name appears in WizUnzip's title bar.
From that point forward, WizUnzip's listbox and button operations apply to the open file. 
WizUnzip can open only one .ZIP file at a time. It is not necessary to close or save the file 
before exiting WizUnzip.

113# HELPID_OPEN_FILE
114$ Opening an Archive File
115+ procedures:005
116K opening;archive



#117$118+119K120Showing the Archive Comment

Some .ZIP archive files contain a readable comment. If you have opened an archive which 
has a comment, the Show Comment button will be active. If the archive has no comment, 
then the Show Comment button will be grayed.    You may display the comment by selecting 
the Show Comment button with the mouse or by typing Control-S. 

The comment will be copied to the Messages window where it may be scrolled using the 
scroll bars or the standard Windows navigation keys. 

117# HELPID_SHOWING_COMMENT
118$ Showing the Archive Comment
119+ procedures:130
120K comment



#121$122+123Archive Directory Listbox

 When you open a .ZIP archive, WizUnzip displays the archive's directory in the Archive 
Directory Listbox at the top of WizUnzip's main window. The contents may be displayed in 
either Long Format or Short Format using the View Menu. The format of the listbox entries 
will be familiar to users of Phil Katz's PKUNZIP program or Info-ZIP's UNZIP program.

The Archive Directory Listbox is an extended, multiple-selection listbox. 
This means you may select multiple files by clicking the mouse on a given item and 
dragging the mouse downward through the listbox to select a number of items. 
You may also press the Control key and click on listbox individual items to make a 
cumulative list.
To select or de-select all files in the listbox at once, use the Edit Menu.

After selecting the files on which you wish to operate, complete the operation by selecting 
either    the Extract Button, the Display Button, or the Test Button.

You may extract, display, or test files directly from the listbox by double-clicking on the 
filenames. To define which action WizUnzip takes when you double-click on a filename, use 
the Options Menu.

The background color of the Archive Directory Listbox heading and total area is the system 
grayed text color.

121# HELPID_LISTBOX
122$ Archive Directory Listbox
123+ screen:010



#124$125+126 Push-buttons

The center of WizUnzip's main window contains four push buttons which let you access the 
contents of the .ZIP archive opened earlier.

124# HELPID_BUTTONS
125$ Push-buttons
126+ screen:020



#127$128+129 Display Button

When active, the Display button copies the selected files shown in the listbox into the 
Messages Window. 

127# HELPID_DISPLAY
128$ Display Button
129+ button:010



#130$131+132 Extract Button

When active, the Extract button de-archives the selected files shown in the listbox into the 
current directory. 

130# HELPID_EXTRACT
131$ Extract Button
132+ button:020



#133$134+135 Test Button

When active, the Test button checks the integrity of the selected files shown in the listbox 
and displays the outcome of the check in the Messages Window. 

133# HELPID_TEST
134$ Test Button
135+ button:030



#136$137+138 Show Comment Button

When active, the Show Comment    button copies the contents of the archive comment into 
the Messages Window where you may browse it. 

136# HELPID_SHOW_COMMENT
137$ Show Comment Button
138+ button:040



#139$140+141 Messages Window

At the bottom of WizUnzip's main window is    the Messages window, in which WizUnzip 
displays three types of information from the archive:

1) a record of file extraction and file testing (see Extracting Files from the Archive),
2) text files to browse (see Browsing Text in the Archive),
3) comments (see Showing the Archive Comment).

The Messages window may be scrolled horizontally or vertically using either the mouse    or 
standard Windows navigation keys.    

You can maximize the Messages window within WizUnzip's main window by clicking on the 
Messages window's maximize box or by selecting the Maximize entry from the Messages 
window's system menu.    When maximized, the Messages window covers the listbox and 
pushbuttons. 

You can restore the maximized Messages window by clicking on the Messages window's 
maximize box again or by selecting the Minimize entry from the Messages window's system 
menu.

You can clear the Messages window using the Clear Messages Window menu item from the 
Edit Menu or by typing the Del key.    The Messages window automatically clears itself to 
make room for more information when either of the following happens:

1) the number of characters in the buffer reaches 65535, or
2) your system does not have enough global buffer space to contain more data.

139# HELPID_MSG_WINDOW
140$ Messages Window
141+ screen:030



#142$143+144Title Bar

The title bar shows which archive file is currently open and into which directory WizUnzip 
extracts.

If no ZIP archive is open, the title bar contains the message (No ZIP File) in the file name 
field.

142# HELPID_TITLE_BAR
143$ Title Bar
144+ screen:070



#145$146+147Icon
The WizUnzip icon's title includes the name of the current archive file name. 
If no ZIP archive is open, the title bar contains the message (No ZIP File) in the file name 
field.

The WizUnzip icon starts out as a fully zipped zipper. 

After extracting the first file, the WizUnzip icon changes into an unzipped zipper.

That's as close as WizUnzip comes to snappy graphics and animation.

The icon artwork is by Becky Cobb.

145# HELPID_ICON
146$ Icon
147+ screen:080



#148Becky Cobb

"No one can do
      What Becky can do
In just thirty-two
      By thirty-two."

148# term_becky



#149$150+151Error Messages in the Messages Window

This section describes some of the error messages which can appear in the Messages 
Window.

filename:    encrypted (can't do yet)--skipping.
This message indicates an encrypted file was found in the archive. Since decryption is not 
supported in the current version of WizUnzip, the file is skipped.

End-of-central-directory signature not found.    Either this file is not
          a zipfile, or it constitutes one disk of a multi-part archive.    In the
          latter case the central directory and zipfile comment will be found on
          the last disk(s) of this archive.
This error means that the opened file is either not in ZIP archive format or is a corrupted ZIP 
file.    Check the suffix of the file. This error might occur if you transferred the archive across 
a network as an ASCII file rather than as a binary file. At any rate, WizUnzip can't decipher it.

error: can't open zipfile [ filename ]
This message appears if the archive file has been moved or deleted after having been 
opened in WizUnzip.

error:    expected central file header signature not found (file #n).
This error means that the opened file is either not in ZIP archive format or is a corrupted ZIP 
file.    Check the suffix of the file. This error might occur if you transferred the archive across 
a network as an ASCII file rather than as binary file. At any rate, WizUnzip can't decipher it.

Expanding: filename    status
Exploding: filename    status
Extracting: filename    status
Testing:filename    status
UnShrinking:filename    status
These messages occur during extraction or testing. During extraction they indicate which 
compression technique was employed to archive the file named filename.    The status value 
can be either 

OK,    which means success, 

or

Bad CRC xxxxxxxx    (should be xxxxxxxx), which means the file is corrupted in the 
archive,

where xxxxxxxx is a hexadecimal number.

Fatal write error
This message might appear if the disk had filled up while extracting a file.

filename    unknown compression method
This indicates that WizUnzip cannot extract the given file. The cause is possibly due to a 
corrupted archive or the file was stored using a technique designed after this version of 

149# HELPID_MSGWIN_ERRORS
150$ In the Messages Window
151+ errors:010



WizUnzip.

warning:    didn't find end-of-central-dir signature at end of central dir.
This error indicates that the opened file is either not in ZIP archive format or is a corrupted 
ZIP file.    Check the suffix of the file. This error might occur if you transferred the archive 
across a network as an ASCII file rather than as a binary file. 

warning:    filename too long--truncating
This error might appear when extracting a file generated on a system other than DOS. The 
name exceeds DOS's 8.3 format.



#152$153+154Error Messages in Dialog Boxes

This section describes error messages which may appear in a Windows message box.

Cannot open filename
Appears in the Open a ZIP File dialog box if you specify a file that doesn't exist.
Can also appear if you specify a file which does not exist when starting up WizUnzip with a 
filename argument.

Clearing Messages window to make room for more information.
Appears if the Messages window buffer becomes full or otherwise cannot grow.

152# HELPID_MSGBOX_ERRORS
153$ Error Messages in Dialog Boxes
154+ errors:020



#155$156+157Who is Info-ZIP ?

This is an incomplete list of some of the people who helped in the testing and/or porting of 
Info-ZIP's unzip to various machines:

386i: Richard Stephen, stephen@corp.telecom.co.nz
3Bx: Bob Kemp, hrrca!bobc@cbnewse.att.com
amdahl: Kim DeVaughn, ked01@juts.ccc.amdahl.com
apollo: Tim Geibelhaus
aviion: Bruce Kahn, bkahn@archive.webo.dg.com
coherent: David Fenyes, dfenyes@thesis1.med.uth.tmc.edu
cray: Greg Roelofs, roelofs@amelia.nas.nasa.gov
dec5820: "Moby" Dick O'Connor, djo7613@u.washington.edu
dnix: Bo Kullmar, bk@kullmar.se
gould: Onno van der Linden, linden@fwi.uva.nl
hk68: John Limpert, gronk!johnl@uunet.UU.NET
hp: Randy McCaskile, rmccask@seas.gwu.edu (HP-UX)

Gershon Elber, gershon@cs.utah.edu (HP BSD 4.3)
mips: Peter Jones, jones@mips1.uqam.ca
msc_dos: Greg Roelofs
msc_os2: Wim Bonner, wbonner@yoda.eecs.wsu.edu
mswindows Robert Heath, heath@ncrcae.columbiasc.ncr.com
ncr sys3k Robert Heath, heath@ncrcae.columbiasc.ncr.com
ncr tower Robert Heath, heath@ncrcae.columbiasc.ncr.com
next: Mark Adler, madler@piglet.caltech.edu
p_iris: Valter V. Cavecchia 
pyramid: James Dugal, jpd@usl.edu
rtaix: Erik-Jan Vens
sco: Onno van der Linden (SCO Unix 3.2.0)

Bill Davidsen, davidsen@crdos1.crd.ge.com (Xenix/386)
sco_dos: Bill Davidsen
sco_x286: Ricky Mobley, ddi1!lrark!rick@uunet.UU.NET
sequent: Phil Howard, phil@ux1.cso.uiuc.edu
sgi: Greg Roelofs
sun: Onno van der Linden (Sun 4)
tahoe: Mark Edwards, mce%sdcc10@ucsd.edu
ultrix_vax: Greg Flint, afc@klaatu.cc.purdue.edu

Alex A Sergejew    <aas@cc.uq.edu.au>
ultrix_risc: Michael Graff, explorer@iastate.edu
vax: Forrest Gehrke, feg@dodger.att.com (SysV)

David Kirschbaum, kirsch@usasoc.soc.mil (BSD 4.3)
Jim Steiner, steiner@pica.army.mil (8600+Ultrix)

wombat: Joe Isuzu, joe@trustme.isuzu.com

155# HELPID_INFO_ZIP
156$ Who is Info-ZIP?
157+ product_info:010



#158$159+160Copyright and Distribution

Where to Find Info-ZIP Archives

If you have Internet access, you can find Info-ZIP products on the system valeria.
Valeria's full Internet name is valeria.cs.ucla.edu (131.179.64.36).
FTP as user "anonymous" with any password.
The archive directory is info-zip.
WizUnzip version 1.1 is archived as the file wzun11.zip under info-zip/Windows.

Sam Smith's Copyright

Unzip version 4.11 is descended from Samuel H. Smith's original unzip code of 1989.
Portions of that original source code contained this notice:

            * Copyright 1989 Samuel H. Smith;    All rights reserved
          *
          * Do not distribute modified versions without my permission.
          * Do not remove or alter this notice or any other copyright notice.
          * If you use this in your own program you must distribute source code.
          * Do not use any of this in a commercial product.

Due to numerous revisions and enhancements by Info-ZIP and many unrecognized 
contributors, unzip 4.11 bears little resemblence to Samuel Smith's original code. 
Though Samuel Smith has declined to respond to inquiries, many members of Info-ZIP    feel 
that unzip 4.11 satisfies the intent of Samuel Smith's restrictions.
Unzip 4.11 is freely available in source and in binary form on a non-profit basis.

Source code for Unzip version 4.11, on which WizUnzip is based,    is available on valeria as 
the archive unzip411.zip.

I Place My Portion in the Public Domain

The Info-ZIP developers have chosen not to copyright unzip.
I, Robert A. Heath, am the author of the Microsoft Windows interface version of UNZIP, which
I call WizUnzip. 
I place the portion which I wrote in the public domain. 
I give you my permission to distribute my portion without condition. 
You may make derivative works from the source when available. 

The Microsoft `C' source code for WizUnzip 1.1 resides on the Internet system valeria. It's 
under info-zip/Windows.
The source code archive is named wzun11sr.zip .

158# HELPID_DISTRN
159$ Distribution
160+ product_info:020



#161 Beginning Windows programmers may wish to snarf the code that makes up the 
Messages window. Heck, I wish I'd had some of that code before now.

161# term_derivative



How to Get Info-ZIP Archives

On the Internet, archives for INFO-ZIP are on valeria.cs.ucla.edu (131.179.64.36).
FTP as user "anonymous" with any password; then "cd info-zip".
Past issues of the digest are in the "info-zip/MAIL" directory.

ZIP 1.0 (first public release!) is available via anonymous FTP from
valeria.cs.ucla.edu, in the directory "pub", as "zip10ex.zip" or
"zip10ex.tar.Z".

If you don't have anonymous FTP capability, you can mail one of the fol-
lowing commands to listserv@vm1.nodak.edu or listserv@vm.ecs.rpi.edu in
order to get a copy via e-mail:

                      /pdget mail pd:<misc.unix>zip10ex.zip uuencode
          or        /pdget mail pd:<misc.unix>zip10ex.tar-z uuencode



#162$163+164Warranty or Lack Thereof

I make no promises express or implied on the suitability of this software product for any 
particular purpose. All responsibility for use of WizUnzip lies with the user.

162# HELPID_WARRANTY
163$ Warranty
164+ product_info:030



#165$166+167History

Date Version Description
Jan. 27, 1992 1.0 Original Release.
Apr. 26, 1992 1.1 Fixes problem in LF to CR,LF 

mapping. Renamed "Translate LF 
to CR,LF" option to "Translate 
CR,LF to LF". 
Release of source.

165# HELPID_HISTORY
166$ History
167+ product_info:040



#168$169+170Help Overview

WizUnzip offers three varieties of help:

WizUnzip Help Help specific to WizUnzip
Using Windows Help How to Use Windows Help in General
About Version and Author

168# HELPID_OVERVIEW
169$ Help Overview
170+ commands:50



#171$172+173WizUnzip Help

WizUnzip has standard Windows help accessed by typing the F1 key.    This method takes you
to WizUnzip's top help index. You may use the mouse or keyboard to select lower-level topics
or to simply browse.

WizUnzip also has context help by which you can hit Shift-F1, producing the 
question-mark/arrow cursor. You may then select any of WizUnzip's menu items using the 
mouse or the keyboard.    Context help takes you directly to the help screen associated with 
the desired menu item.

171# HELPID_HELP
172$ WizUnzip Help
173+ help:020



#174$175+176Using Windows Help

This menu entry takes you to the standard introduction on using Windows help.

174# HELPID_HELP_HELP
175$ Using Windows Help
176+ help:030



#177$178+179About

The about box gives the latest program version number and information about the author.

177# HELPID_ABOUT
178$ About
179+ help:040


